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LAB 18 - Tab Sheets 

This lab demonstrates the functionality build into the standardized tab sheets.  It highlights the ability to 
quickly modify the sheet’s structure by adding and removing columns and dividing the sheet so that it will fit 
within the sheet border.  The functionality is similar with all of the standardized tab sheets.  This lab uses the 
DES_Tabulation of Surfacing.xls file for the exercises.

Chapter Objectives:

 Update the Pay Item File location

 Add additional columns to the table

 Delete columns from the table

 Modify fields associated with asphalt pay items

 Add additional rows to the table

 Enter data in the new rows and columns

 Divide the main sheet into sub sheets

 Link the sub sheets to a MicroStation sheet border.

The files used in this lab are:

 C:\Projects\12345\Design\Drawings\Tabs\12345DES_Tabulation of Surfacing.xls 

 C:\Projects\12345\Design\Drawings\12345DES_TabMisc##.dgn

Lab 18.1 -  Update the Pay Item File location 

In order for the tab sheet to function properly, it must access the Trnsport_Itemlist.csv file.  The location of this 
file is specified in cell D1 of the Surfacing Sheet worksheet. This exercise demonstrates how to select the the 
Trnsport_Itemlist.csv file’s location.

1. Start Excel and select File > Open.

2. In the Open dialog box, navigate to C:\Projects\12345\Design\Drawings\Tabs.

3. Highlight the 12345DES_Tabulation of Surfacing.xls file and <D> Open.

Notice that the text for the Pay Item File is red.  This indicates that the file is not found.  
Without this file, additional pay items cannot be added.  To locate the Trnsport_Itemlist.csv 
file:
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4. <D> the Update / Browse for Pay Item File button.  This displays the Update / 
Browse for Pay Item File dialog box.

5. <D> The Browse for Pay Item File button. This displays the Open dialog box.

6. Navigate to the C:\Workspace\Workspace-CDOT_XM\Standards-Global\ directory.
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7. Highlight the Trnsport_Itemlist.csv file and <D> Open.

8. <D> the Return to Excel button in the Update / Browse for Pay Item File dialog box.

The text for the Pay Item File is now black, indicating that the Trnsport_Itemlist.csv file is 
available for use.
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Lab 18.2 -  Adding a Pay Item

There are times when additional pay items need to be added after work has begun on the tabulation sheet.  The 
standardized tab sheet can add and sort the additional columns, keeping the existing data in the sheet with its 
proper pay item.  In this exercise, a column for Removal of concrete pavement is added.

The illustration above shows the sheet before adding the column.

1. <D> the Data Entry button.  This displays the Surfacing Data Entry dialog box.

2. Scroll down the list of pay items and highlight the 202-00210 Removal of Concrete 
Pavement pay item.



Colorado Department of Transportation   Page 343

Labs for InRoads XM LAB 18 - Tab Sheets 

3. <D> the Add Items button.

4. <D> Close to dismiss the Surfacing Data Entry dialog box.
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Notice that the Removal of Concrete Pavement is now the first pay item column on the sheet.  
Also note that the data in the sheet was shifted to keep it with the proper pay item.

The illustration above shows the sheet after the new column is added.

Lab 18.3 -  Deleting a Pay Item

Sometimes pay items originally added to the sheet are not used.  The standardized tab sheet can 
remove the specified columns and reorganize the remaining data.  In this exercise, the column 
for patching asphalt is removed.

1. <D> the Data Entry button.  This displays the Surfacing Data Entry dialog box.

2. <D> the Delete a Pay Item already placed in sheet button.  This displays the 
Delete Item dialog box.

3. Highlight the 403-00721 Hot Mix Asphalt (Patching) (Asphalt) pay item.
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4. <D> the  Delete Item button.

5. <D> Close on the Delete Item and the Surfacing Data Entry dialog boxes.

Notice that the patching asphalt column is gone and the columns to the right have shifted over.  
The illustration below shows the final layout.
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Lab 18.4 -  Additional Fields Associated with HMA Pay Items

Unlike concrete, asphalt pavement is laid down in a series of lifts.  Each lift making up the total pavement 
thickness could be a different thickness and/or a different grade (which uses a different pay item code).  The 
DES_Tabulation of Surfacing.xls  In addition, extra material is often added to the first (Bottom) lift of asphalt 
to account for irregularities in the ground surface.  These items are accounted for in the tabulation sheet with 
two fields outside of the table and a heading row within the table. For the exercise below, the pavement 
contains three lifts of PG 64-22 asphalt and one lift (the top lift) of PG 76-28 asphalt.  The sheet shows four 
lifts of PG 64-22 asphalt and one lift  of PG 76-28 asphalt listed as a bottom lift.  It will also use an irregularity 
factor of 2% where the sheet currently shows 5%.  The sheet will be modified to match the pavement 
description given above.

1. <D> in the Number of Lifts cell for the 403-34841 Hot Mix Asphalt (Grading SX) (100) 
(PG 64-22) pay item. (cell I4 in this exercise)

2. Use the drop down menu and select 3 from the list.
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The original Lift 2 row was deleted (including the data).  The Lift 3 and Top rows were shifted 
over and renamed.  The illustration below shows the results.

Next, the lift headings for the Top lift of the PG 64-22 asphalt and the lift of PG 76-28 are 
modified.

3. <D> in cell K9 (it reads Top under the PG 64-22 main heading).

4. Key in Lift 3 and press the Enter key.

5. <D> in cell K10.

6. Key in Top and press the Enter key.

This changes the lift headings for the two asphalt items.  The spreadsheet looks at these 
headings to determine if the irregularity factor is applied.  The irregularity factor is applied to 
the Bottom lift only and if the PG 76-28 lift heading was not changed it would result in an 
erroneous total.  The illustration below shows the changes made.



Page 348 Colorado Department of Transportation

LAB 18 - Tab Sheets Labs for InRoads XM

Finally, the irregularity factor for the PG 64-22 is changed.  The irregularity factor for the PG 
76-28 does not have to be changed because it is not a Bottom lift.

7. <D> in cell I4. This is the % Irreg to Apply: cell for the 403-34841 Hot Mix Asphalt 
(Grading SX) (100) (PG 64-22) pay item.

8. Key in 2 and press the Enter key.  The change is made in cell I4.  This value is used to 
determine the total amount of material used for irregularities at the bottom of the sheet.

Lab 18.5 - Adding Additional Rows

It is possible that additional rows for data are required.  These can be added using the functionality built into 
Excel.  In this exercise, two additional rows are needed.

1. Highlight rows 32 and 33.  To do this, <D> and hold on the row number 32 and drag 
through number 33 and release.

2. <R> in the highlighted area and select Insert from the menu.

The additional rows are added above row 32.

Lab 18.6 -  Add Additional Data to the Sheet

Now that the sheet is set up, the quantities for the new columns and rows can be added.  Station extents for the 
last five rows are needed.  At the top of the sheet, quantities for removal of concrete pavement are added.  At 
the bottom, the quantities associated with the asphalt pavement are added. ( Note: on an actual project the 
quantity values are calculated based on design data prior to creating this sheet.  Here we are inserting an 
arbitrary value to demonstrate the functionality of the sheet.)

1. <D> in cell F10.  This is the first quantity cell of the removal of concrete pavement pay 
item.

2. Key in 132 and press the Enter key.  This represents the number of square yards of 
concrete pavement removed between station 1+00 and 5+00.
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3. Press Enter twice more.  The cursor is in cell I13.

4. Key in 247 and press Enter.

5. Key in 316 and press Enter.  This is in cell I14.

6. Scroll so that the Project Totals line is visible.  The total for removal of concrete 
pavement is 695.

Next enter the station numbers for the last three lines.  The stations are in 700 foot intervals.

7. <D> in field C32.  This is the first empty cell in the From station field.

8. Key in 15000 and press the Enter key.  This is 700 more the value in the cell above.

9. Continuing entering stations (adding 700 each time) down to cell C36.

10. Repeat this process in the To station column.  The illustration below shows the completed 
station columns.
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11. To finish the data entry, copy the data from row 31 – columns H through O into rows 32 
through 36.  The illustration below shows the completed data entry.
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12. Examine the totals for the Asphalt pay items.  Note:

♦ An irregularities total only for the bottom lift of asphalt

♦ Sub totals for each lift of PG 64-22

♦ A grand total for PG 64-22

Lab 18.7 - Dividing the Surfacing Sheet into Sub Sheets

It the sheet is too long to fit inside the sheet border, there is a option to divide the master sheet into sub sheets 
of a specified number of data rows.  When this option is selected, additional worksheets are added to the file 
that contain a part of the master sheet along with a sheet totals table.  In this exercise, it was decided the 20 
rows of data was the maximum per sheet. (this number will vary based on the tab sheet being used and 
additional information that may be included in the printable sheet.)

1. Scroll to the top of the sheet (if it is not there already).

2. <D> the Divide Sheet button.  This displays the Sheet Rows dialog box.

3. Key in 20.  This is the number of data rows used on each sub sheet.
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4. <D> OK.

Two sub sheets (Sub Sheet 1 and Sub Sheet 2) were created along with Sub Sheet Totals.

The master sheet (Surfacing Sheet) is left intact.  To re divide the master sheet by a different 
number of rows, delete the sub sheets and run through the process again.

5. Save but do not close the file.

Lab 18.8 - Link the Sub Sheets to a MicroStation Sheet Border

The final step in creating the tab sheet is to link the Excel file to the MicroStation sheet border.  Linking allows 
the Excel file to be updated and reflect those updates in the MicroStation file.  In this exercise, Sub Sheet 1 is 
linked to the sheet border file.  The process is the same for the other sub sheets.

The first step in linking the spreadsheet is to prepare the MicroStation file.  The miscellaneous 
tab sheet border is copied and renamed to be the surfacing tab sheet.

1. Start MicroStation and open 12345DES_TabMisc##.dgn.

2. Select File > Save As from the MicroStation menu bar.

3. Key in 12345DES_TabSurf01.dgn in the File name field.
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4. <D> Save.  This creates the new file and opens it.

5. Bring Excel to the front.

6. Select the Sub Sheet 1 worksheet.

7. Highlight cells C2 through P29.  This is the entire table.

8. Select Edit > Copy from the Excel menu bar.

9. Bring MicroStation to the front.
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10.  Select Edit > Paste Special from the menu bar. This displays the Paste Special dialog 
box.

11. In the Paste Special dialog box, highlight Linked Microsoft Office Excel 2003 
Worksheet.

12. <D> Paste. This displays the Paste OLE Object tool settings box.

13. In the Paste OLE Object tool settings box, set the Method to By Size.
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14. In the Scale field key in 8.500.  This makes the text in the Excel file the proper size for 
the MicroStation file.

15. A dashed box is connected to the cursor.  This represents the size of the table that is being 
placed.  Center it inside the sheet border and <D>.  The file is now linked to the sheet 
border file.

16. The hatching in the table indicates that the Excel file is open.  Bring Excel to the front and 
close it to remove the hatching.  The illustration shows the final result.

17. Close MicroStation.
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Chapter Summary:

 The tab sheets use the Trnsport_Itemlist.csv file to set the column headings for the tab 
sheet.

  The Trnsport_Itemlist.csv file is updated by ServerCop at log in or it can be manually 
updated.

 Programming that automates the layout and revision of the column headings is accessed 
through various buttons placed in the worksheet.

 Rows are added or deleted using standard Excel functionality.

 Large tab sheets can be divided to fit into multiple sheet borders.

 If the tab sheet is divided, a sheet totals table is also created.

 The tab sheets are linked to a MicroStation sheet border for printing


